SIG meeting notes fuerte/Planning/TurtleBot/2011-09-26
Today's Focus Software:
Melonee proposes REP for canonical turtlebot base, including naming conventions for topics, links, breaker names.
- Change to "camera" for link name and topic name for kinect/future sensors.
- This will allow most demos/examples with camera code which will work without remapping.
- Additional cameras/depth sensors would get a specific name like "head_camera" for example patrick's pan tilt camera.
- Conform with REP 105
Should consider a seperate standard for simple arms and heads.
- Arm link name standards, such as arm base link
- Base head link names.
- Should be easily mapped to multi arm configurations.
Breaker Names
- Stick with numbered.
- In the future we can add a "breaker controller" which will abstract breaker names to numbers.
Launch Files
- Suppress non user launchable files.
- Collapse as many launch files as possible into as few as possible.
- Simplify use cases as much as possible.
Move into laser_pipeline/laser_geometry
should move prints to ROS_INFO leave IR sensor upgrade ticket for a motivated user.
Service updates:
- Change Upstart to restart on new IP instead of stop on loss of interface.
- Seperate upstart service for roscore
- Add use_sim_time = False in hardware bringup
- add a service reload/restart target for turtlebot which won't kill the roscore.
Promote laptop_battery into a general location. Also, pull CPU stuff from PR2 possibly make a stack computer_diagnostics.
Move turtlebot_interactive_markers to turtlebot_viz stack
- Rename chirp to turtlebot_sounds.
- follow up turtlebot_actions API review
- move turtlebot_navigation_laser into turtlebot_navigation
- review turtlebot_self_filter and should it be added into navigation, or does navigation do that for us?
- make display a little more intuitive
- fix crashes when pressing non mapped keys.
- look at bringing in teleop_twist from Brown
promote turtlebot_train and turtlebot_rndmwalk into turtlebot_apps